Our pure JavaScript Scheduler component

Post by sudhabalu »

We are using bryntum scheduler trial version 5.1.1 (Offline mode). We are facing the following issues when strict mode is enabled in react 18.

  1. Initial zoom is not coming properly. We have to manually zoom in to required place.
  2. Custom resource model is not working.
  3. viewPreset is not working whatever the values we provide.

I have attached the source code for your reference.

Steps to reproduce:

  1. Install packages using yarn install
  2. Start the project using yarn start
  3. Goto URL https://localhost:3000/
  4. You can view all the above mentioned issues. You can also remove React.Strict mode in App.js file to confirm all the functionalities are working fine without strict mode in React 18.

Note: It is working fine if React.Strict mode is disabled. Can you fix this as we are using strict mode for all components in the application.

Source to reproduce issue
(8.38 MiB) Downloaded 33 times

Post by tasnim »

Hi, sudhabalu,
We already have a ticket on that. Here it is : https://github.com/bryntum/support/issues/4654
There are known problems with using StrictMode in React v18 in dev mode.
Please see

Post by sudhabalu »

Hi Tasnim,

Thanks for your reply. May I know when it will get resolved as we are evaluating the Bryutum scheduler to include in our React project which requires strict mode as mandatory for all components without any compromise. This will help us to plan the purchase.

Post by alex.l »

We didn't plan to fix it in nearest release, so it takes more than 1 month, I can't provide any exact terms unfortunately. We also not 100% sure we will be able to fix this ourselves since it's a bug in React as well. But our developers said we will.
I will notify product management about your request and try to push it a bit, if it's possible.
It's also possible React team will fix it faster, who knows.

All the best,

Post Reply