Premium support for our pure JavaScript UI components

Post by jan@veovo »

Hello Bryntum Team,

I have a problem with configuring Bryntum dragging between schedulers using as an example. But after drag ends it throws error in console:

ERROR Error: Uncaught (in promise): TypeError: record.instanceMeta is not a function
TypeError: record.instanceMeta is not a function
    at SchedulerPro.isInTimeAxis (schedulerpro.module.js:173407:20)
    at schedulerpro.module.js:154121:36
    at (<anonymous>)
    at asyncGeneratorStep (asyncToGenerator.js:3:24)
    at _next (asyncToGenerator.js:22:9)
    at asyncToGenerator.js:27:7
    at new ZoneAwarePromise (zone.js:1429:21)
    at asyncToGenerator.js:19:12
    at EventDrag.updateAssignments (schedulerpro.module.js:154187:6)
    at schedulerpro.module.js:153802:25
    at resolvePromise (zone.js:1211:31)
    at zone.js:1118:17
    at zone.js:1134:33
    at _ZoneDelegate.invoke (zone.js:372:26)
    at Object.onInvoke (core.mjs:24313:33)
    at _ZoneDelegate.invoke (zone.js:371:52)
    at (zone.js:134:43)
    at zone.js:1275:36
    at _ZoneDelegate.invokeTask (zone.js:406:31)
    at core.mjs:23999:55

After some debugging it looks like isInTimeAxis function gets record's id as value instead of reference to dragged record and this is done in:

// Pro Engine does not seem to handle having the event already in place on the copied assignment,
// replacing it with id to have events bucket properly set up on commit
if (newAssignment.event) {
  newAssignment.event =;
  newAssignment.resource =;

Not sure if i'm doing something wrong?
Also here is drag configuration:

eventDrag: {
	showTooltip: false,
	constrainDragToTimeSlot: true,
	constrainDragToTimeline: false

Post by tasnim »


I tried to reproduce it in with the eventDrag config.
But I wasn't able to repro the issue.

Could you please provide some more details on how to reproduce it?

Best of luck,

Post by jan@veovo »

Hello Tasnim,

I managed to reproduce this issue on when dragging the event to second scheduler and than again to the original one the same error throws in console. One thing I noticed is that this does not occur when schedulers share the event store. Is that the case? I didn't find any information if partnered shedulers must have the same event store?

Post by mats »

Looks like a clear bug yes, thanks for the test case!

Post Reply