Premium support for our pure JavaScript UI components


Post by Vinodh Kumar »

When i try to install bryntum gantt 5.6.7 it is throws an error. Please find the below error. Can you please help how to resolve this issue.

npm ERR! code UNABLE_TO_GET_ISSUER_CERT_LOCALLY
npm ERR! errno UNABLE_TO_GET_ISSUER_CERT_LOCALLY
npm ERR! request to https://npm.bryntum.com/@bryntum%2fgantt failed, reason: unable to get local issuer certificate

npm ERR! A complete log of this run can be found in: C:\Users\vinodh.karumuri\AppData\Local\npm-cache\_logs\2024-02-26T11_33_40_049Z-debug-0.log


Post by sergey.maltsev »

Hi!

Please attach full npm log.
I can confirm, that npm sever works and I was is able to install our packages


Post by Vinodh Kumar »

Attached the log file

Attachments
2024-02-26T12_52_24_593Z-debug-0.log
(468.48 KiB) Downloaded 17 times

Post by khattakdev »

Hey Vinodh,

This can happen of multiple reasons. Can you share your npm configuration (npm config list --json)

Arsalan
Developer Advocate


Post by sergey.maltsev »

Hi!

Please try removing global npm packages and try again.
Seems that you use minipass-fetch npm module, which is nonstandard one.


Post Reply